View on GitHub

DPM

A Package Manager for Delphi

Supported Compiler Versions

DPM supports Delphi XE2 - 10.3 +

We may consider support for D2009/D2010/XE but at this stage it does not compile. Support for earlier versions is not planned, it’s time to upgrade people.

What about FPC

We have no plans for FPC support at this time. If someone is willing to put the effort in we would consider a contribution. However, FPC project files etc are very different. DPM leverages the fact that Delphi uses msbuild for it’s dproj files.

What about C++ Builder

This is something we would like to see. However, we lack the expertise to do this right now. If you have that expertise and are willing to help then contact the team.